人才社区

 找回密码
 免费入驻

QQ登录

只需一步,快速开始

搜索
查看: 585|回复: 0

[已解决] 您的服务器无法访问应用中心,这将会导致应用无法安装。请联系您的服务商或者网站技术人员,确保您的服务器能够正常访问addon.discuz.com或addon1解决

[复制链接]

51

主题

53

帖子

390

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
390
发表于 2019-2-23 22:28:25 | 显示全部楼层 |阅读模式
人才港关于 discuz 后台访问应用中心或更多插件时提示:“您的服务器无法访问应用中心,这将会导致应用无法安装。请联系您的服务商或者网站技术人员,确保您的服务器能够正常访问 addon.discuz.com 或 addon1.discuz.com”或者是 discuz 应用中心安装插件模板提示”错误:数据无法识别,请返回“的解决方法。

百度搜了一下看着遇到这样问题的用户还很多,discuzX3.2 、discuzX3.3、discuzX3.4都有遇到这种情况的, 有很多网站提供解决办法,但实际都没什么帮助,今天灵机一动 终于把“数据无法识别,请返回” 这个问题给解决了……




解决方法很简单,请查看官方公告:

      关于 Discuz! 应用中心、Discuz! 开放平台升级 HTTPS 的公告

  随着 Discuz! 应用中心及Discuz! 开放平台的相关业务发展,为了进一步提升保障平台的稳定安全性及高效的服务,平台将在近期全面升级 HTTPS 协议。届时将有短暂的无法访问时间,由此给您带来的不便,深表歉意!

  升级 HTTPS 协议后,应用的下载接口也将变为 HTTPS 协议,如有任何访问及应用下载等问题,请先用此工具自测 https_test.zip (1.57 KB, 下载次数: 3330) ,如果仍无法解决请与平台客服取得联系。

  感谢您一直以来对平台的关注与支持,我们将不断优化产品功能,为您提供更好的体验和服务,如您有任何意见和建议欢迎联系平台在线客服,您的反馈是我们不断发展的动力!

  对于discuzX3.2 、discuzX3.3、discuzX3.4等X3以上版本,请把 source/function/function_cloudaddons.php 文件中所有的 “http://” 替换为 “https://”。
       对于 X3 及以下版本,请安装此补丁 addon_https_patch.zip (2.68 KB, 下载次数: 1958)

  PS:要完整体验 https 下的应用中心,首先要求 PHP 环境 5.3 以上,太老的 PHP 版本请自行升级
         然后,可修改 source/function/function_cloudaddons.php 文件,把所有的 “http://” 替换为 “https://


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?免费入驻

x
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 免费入驻

本版积分规则

快速回复 返回顶部 返回列表